Thursday, June 13, 2013

GUIDE: Kdenlive on Windows, Properly!

Introduction

So, you want to install and use Kdenlive on M$ Windows, but don't want to do all that crazy Live-CD sh*t (probably because that's not technically doing it in Windows)?

Well, you've come to the right place (website, whatever)!

This guide will show you how to install Kdenlive inside Microsoft Windows, by using Cygwin, Cygwin/X and Cygwin Ports.

This guide assumes you know your way around a command prompt/terminal window. If you don't, turn back now!

The Guide

1. Download setup.exe from http://www.cygwin.org/setup-x86.exe. Save it to a folder on your desktop.

2. Open up a command prompt and navigate to the folder where setup.exe is.

3. Run setup.exe -X -K http://cygwinports.org/ports.gpg.

4. Accept the default options until you get to this screen. Choose the download site closest to you. If you don’t know, just pick a random one. Do not press Next! Enter ftp://ftp.cygwinports.org/pub/cygwinports in the User URL box and press Add.

5. Now press Next, and wait for the files to download. This could take a while.

6. Type kde into the search bar and click the Skip text next to kde-runtime, kde-workspace and kdenlive.

7. Type xorg-server into the search bar and click the Skip text next to xorg-server.

8.  Type xinit into the search bar and click the Skip text next to xinit.

9. Click Next a couple of times, accepting the defaults, and wait for the files to download and install. This will likely take quite a while.

10. Once it’s finished you should be (almost) good to go!

11. Open up Cygwin and type in echo exec startkde>~/.xinitrc.

12. Type in startx.

13. Hopefully, KDE should start booting! Once it finishes, you should be able to launch Kdenlive through the menu!


Labels: , , , , , ,

24 Comments:

At September 1, 2013 at 8:39 PM , Blogger Blog do Cláudio said...

First thanks for your nice job.
Now when I try to install from Cygwin I am genting an error:

"Download Incomplete. Try Again?"

I tried again many times and the error continues.
Do you know what is happening and how to solve this issue?

I tried other mirrors but without success.

 
At September 7, 2013 at 7:02 PM , Blogger RunasSudo said...

Try using ‘ftp://ftp.cygwinports.org/pub/cygwinports’ instead of the Sourceforge mirror in step 4.

 
At September 10, 2013 at 8:22 PM , Blogger Blog do Cláudio said...

It worked. Thanks a lot.

 
At November 19, 2013 at 2:09 PM , Blogger Sebastian Wojciechowski said...

Hello, i try install but i cant find (step 6) kdebase-startkde : KDE desctop startup script, (step 7) xorg-server: X. Org X servers (step 8) xinit. I use this url http://cygwin.com/setup-x86_64.exe , becouse http://cygwin.com/setup.exe doesn't exist. Please for help with this problem.

 
At November 22, 2013 at 3:51 PM , Blogger RunasSudo said...

Are you sure you added and selected ’ftp://ftp.cygwinports.org/pub/cygwinports’ as a mirror in step 4?

 
At November 24, 2013 at 5:32 AM , Blogger Sebastian Wojciechowski said...

yes, i try again and that same problem :/

 
At November 24, 2013 at 9:52 PM , Blogger RunasSudo said...

Well I don't know what could be happening. It works perfectly fine for me. The only thing I can suggest is to read through the instructions carefully.

 
At November 25, 2013 at 1:06 AM , Blogger Sebastian Wojciechowski said...

I try leater with 32 bit version

 
At November 25, 2013 at 2:27 PM , Blogger Sebastian Wojciechowski said...

i install all again, now 32 bit version, on the list i cant find "kdebase-startkde", there is img of all components after write "kde" http://i.imgur.com/Ny3p96S.jpg , without it this can be , i dont have menu ?

 
At November 25, 2013 at 4:43 PM , Blogger RunasSudo said...

The package appears to have been moved into kde-workspace. Try installing that instead.

 
At November 26, 2013 at 12:47 AM , Blogger Sebastian Wojciechowski said...

I got install kde-runtime, kde-workspace, kdenlive, xorg-server, xinit, without kdebase-startkde. All steps like in instruction, when window open, i see nice backgroud (step 13 1st image), after few sec. backgriund gone to back to black window and i got it without menu, just black window :(

 
At November 26, 2013 at 4:48 PM , Blogger RunasSudo said...

Are there any error messages in the terminal?

 
At November 27, 2013 at 3:40 PM , Blogger Sebastian Wojciechowski said...

Well i install again (ver. 64bit), components kde-runtime, kde-workspace, kdenlive, xorg-server plus installed all components with writen text in search box "menu", "wall", "start" , maybe dont need it, but why not try, after install and run, i got black creen, then i go to right corner to icon Cygwin, RB -> Aplicatrions -> xterm. After close it and Cygwin, system run normaly. Only when i try change background in default Desctop Setings, window back to black, menu gone and i must close window and run again.
There is link to file with all information from terminal http://sdrv.ms/1dBVu4g , regards.

 
At February 17, 2014 at 7:12 PM , Blogger Fred Thompson said...

kdebase-startkde is present in the various ftp archives but appears to be an empty bz2 file. It's only 14 bytes in size.

@RunasSudo, how large is your kdebase-startkde file? Maybe you could post it as an attachment?

I also tried to initiate the plasma desktop but don't know the proper way to do so.

I tried the KDE for Windows 4.10.2 (http://windows.kde.org/) and could launch a desktop but their installer doesn't include kdenlive, I don't know what its dependencies are, and the desktop which launches is semi-transparent and sits on top of the Windows desktop. If KDE for Windows COULD run kdenlive and its desktop can be easily managed, this would be a great option because the installed "OS" base is 1/3 that of cygwin.

 
At February 21, 2014 at 12:55 AM , Blogger RunasSudo said...

According to the kdebase-startkde setup.hint, it has been ‘Obsoleted by kde-workspace’, so you shouldn't need to select it.

I found out earlier and forgot to update the instructions XD

 
At February 21, 2014 at 8:40 PM , Blogger Fred Thompson said...

Does that mean step 11 can be omitted?

When I do that, XWin X Server tried to start and crashes. Here's the report. Do you see anything which might help? It looks to me as if its trying to launch the Plasma desktop which doesn't work on a Windows machine.

Have you tried this process with the current Cygwin? Have you tried copying the files to another computer to see if that works? I ask because my Cygwin file set with kdenlive is about 1.2G. That's easily treated as a portable app.

I'm going to hunt for a way to load an older Cygwin. Methinks the real issue boils down to KDE's plasma and lack of Windows compatibility.

 
At February 26, 2014 at 2:05 PM , Blogger Fred Thompson said...

Well, as of a few days ago, most of the KDE stuff is gone from the Cygwin sites.

@RunasSudo, will you please make an archive of your /Cygwin folder and put somewhere from which Sebastian Wojciechowski and I can download?

 
At March 9, 2014 at 12:25 AM , Blogger RunasSudo said...

Step 11 cannot be omitted, as far as I'm aware.

 
At March 9, 2014 at 12:27 AM , Blogger RunasSudo said...

I'm not sure why you would say that. All the packages I've listed are found on the FTP servers.
ftp://ftp.cygwinports.org/pub/cygwinports/x86/release/kde-runtime/
ftp://ftp.cygwinports.org/pub/cygwinports/x86/release/kde-workspace/
ftp://ftp.cygwinports.org/pub/cygwinports/x86/release/kdenlive/

Are you sure you've added a Cygwin Ports download site? Have you tried using a different Cygwin Ports mirror?

 
At March 9, 2014 at 12:28 AM , Blogger RunasSudo said...

Try doing step 11, and if it still fails, upload the logs to a Pastebin and give me the link.

 
At March 27, 2014 at 5:12 PM , Blogger km said...

Thanks for the instructs, well written, but I do not see any KDE stuff either. Also, note the file is setup-x86_64.exe for the Cygwin64, it took me a while to realize that.

 
At March 29, 2014 at 3:43 PM , Blogger RunasSudo said...

Are you sure the CygwinPorts mirror has been selected in the list? Are there any funny error messages (it once failed to download the package list from CygwinPorts for me)? Can you try using the 32-bit version?

 
At April 16, 2014 at 9:28 AM , Blogger aroger d said...

I've followed your instructions as closely as possible, and when I get to steps 11 and 12, an X window opens, but remains blank. Any thoughts?

 
At April 21, 2014 at 4:44 PM , Blogger RunasSudo said...

Sometimes KDE takes a while to open.

If, after waiting a while, it still doesn't open, please post the console output so I can take a look.

 

Post a Comment

Subscribe to Post Comments [Atom]

<< Home